Sample

An NDoc Documented Class Library

Sample Namespace

Classes

Class | Description
SampleBaseClass | ここに要約を書く
SampleDeriveClass | ここに要約を書く

Interfaces

Interface | Description
ISampleInterface | ここに要約を書く

Delegates

Delegate | Description
SampleEventHandler | ここに要約を書く

Enumerations

Enumeration | Description
SumpleEnum | ここに要約を書く


ISampleInterface Interface

ここに要約を書く

public interface ISampleInterface

Remarks

ここに解説を書く

Requirements

Namespace: Sample Namespace

Assembly: doctest2.dll

See Also

ISampleInterface Members | Sample Namespace


SampleBaseClass Class

ここに要約を書く

For a list of all members of this type, see SampleBaseClass Members.

System.Object
SampleBaseClass

public class SampleBaseClass

Remarks

ここに解説を書く

Example

ここに使用例を書く サンプルコードは以下のように<code>を使う

            class SampleCode {
               ...
            }

Requirements

Namespace: Sample Namespace

Assembly: doctest2.dll

See Also

SampleBaseClass Members | Sample Namespace


SampleBaseClass Members

Public Instance Constructors

SampleBaseClass Constructor Initializes a new instance of the SampleBaseClass class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SampleBaseClass Class | Sample Namespace


SampleBaseClass Constructor

Initializes a new instance of the SampleBaseClass class.

public SampleBaseClass();

See Also

SampleBaseClass Class | SampleBaseClass Members | Sample Namespace


SampleDeriveClass Class

ここに要約を書く

For a list of all members of this type, see SampleDeriveClass Members.

System.Object
SampleBaseClass
SampleDeriveClass

public class SampleDeriveClass : SampleBaseClass, ISampleInterface

Remarks

ここに解説を書く

Example

ここに使用例を書く サンプルコードは以下のように<code>を使う

            class SampleCode {
               ...
            }

Requirements

Namespace: Sample Namespace

Assembly: doctest2.dll

See Also

SampleDeriveClass Members | Sample Namespace


SampleDeriveClass Members

Public Static Fields

SampleConst ここに要約を書く

Public Instance Constructors

SampleDeriveClass Constructor Initializes a new instance of the SampleDeriveClass class.

Public Instance Properties

Property ここに要約を書く

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Method | ここに要約を書く
ToString (inherited from Object) |

Public Instance Events

SampleEvent ここに要約を書く

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SampleDeriveClass Class | Sample Namespace


SampleDeriveClass Constructor

Initializes a new instance of the SampleDeriveClass class.

public SampleDeriveClass();

See Also

SampleDeriveClass Class | SampleDeriveClass Members | Sample Namespace


SampleDeriveClass Fields

The fields of the SampleDeriveClass class are listed below. For a complete list of SampleDeriveClass class members, see the SampleDeriveClass Members topic.

Public Static Fields

SampleConst ここに要約を書く

See Also

SampleDeriveClass Class | Sample Namespace


SampleDeriveClass.SampleConst Field

ここに要約を書く

public const int SampleConst;

Remarks

ここに解説を書く

See Also

SampleDeriveClass Class | SampleDeriveClass Members | Sample Namespace


SampleDeriveClass Properties

The properties of the SampleDeriveClass class are listed below. For a complete list of SampleDeriveClass class members, see the SampleDeriveClass Members topic.

Public Instance Properties

Property ここに要約を書く

See Also

SampleDeriveClass Class | Sample Namespace


SampleDeriveClass.Property Property

ここに要約を書く

public string Property {get; set;}

Property Value

ここにプロパティ値の説明を書く

Remarks

ここに解説を書く

Exceptions

Exception Type | Condition
Exception | ここに例外に意味を書く

Example

ここに使用例を書く サンプルコードは以下のように<code>を使う

            class SampleCode {
               ...
            }

See Also

SampleDeriveClass Class | SampleDeriveClass Members | Sample Namespace


SampleDeriveClass Methods

The methods of the SampleDeriveClass class are listed below. For a complete list of SampleDeriveClass class members, see the SampleDeriveClass Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Method | ここに要約を書く
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SampleDeriveClass Class | Sample Namespace


SampleDeriveClass.Method Method

ここに要約を書く

public int Method(
string Parameter
);

Parameters

Parameter
ここに引数の説明を書く

Return Value

ここに戻り値の説明を書く

Remarks

ここに解説を書く

Exceptions

Exception Type | Condition
Exception | ここに例外に意味を書く

Example

ここに使用例を書く サンプルコードは以下のように<code>を使う

            class SampleCode {
               ...
            }

See Also

SampleDeriveClass Class | SampleDeriveClass Members | Sample Namespace


SampleDeriveClass Events

The events of the SampleDeriveClass class are listed below. For a complete list of SampleDeriveClass class members, see the SampleDeriveClass Members topic.

Public Instance Events

SampleEvent ここに要約を書く

See Also

SampleDeriveClass Class | Sample Namespace


SampleDeriveClass.SampleEvent Event

ここに要約を書く

public event SampleEventHandler SampleEvent;

Remarks

ここに解説を書く

See Also

SampleDeriveClass Class | SampleDeriveClass Members | Sample Namespace


SampleEventHandler Delegate

ここに要約を書く

public delegate void SampleEventHandler(
object sender,
EventArgs e
);

Parameters

sender
イベントのソース
e
イベントデータを格納しているEventArgs。

Remarks

ここに解説を書く

Requirements

Namespace: Sample Namespace

Assembly: doctest2.dll

See Also

Sample Namespace


SumpleEnum Enumeration

ここに要約を書く

public enum SumpleEnum

Members

Member Name | Description
NumberOne | ここに各メンバの説明を書く

Requirements

Namespace: Sample Namespace

Assembly: doctest2.dll

See Also

Sample Namespace